Skip to end of metadata
Go to start of metadata

Transferring Knowledgebases Across Servers

Use the admin console to transfer complete knowledgebases (KBs) to other servers. The Agiloft KB file format makes it possible to transfer tables, table definitions, scripts, escalation rules, inbound email definitions, and other KB customizations, in addition to the source data, format options, and field mappings that can be transferred with simple table exports. 

To transfer the KB to another server, simply export the KB from its current location and import the  Agiloft file on the target server. All tables in the KB are transferred when you use this method, and everything is stored in a single file.

Prerequisites

  • Only the users with project import and export permissions can export the entire knowledgebase in  Agiloft format. To give a group import and export permissions for your knowledgebase, enable the "Allow exporting knowledgebase" option on the General tab of the Group Permissions wizard.
  • You must have access to the admin console to import the knowledgebase on the target server.
  • Check the  Agiloft version on each server. You can transfer KBs from a lower version to a higher version, but not from a higher version to a lower version. To see the current version, log in and go to Help > About  Agiloft in the upper right corner. Note that additional considerations apply when transferring a KB from version 2018_02 or below to version 2019_01 and above.
  • For large knowledgebases, you must have server access to move the file from the source server to the TMP directory on the target server.

Transfer a Knowledgebase to a Different Server

To transfer a KB to another server, export the KB from its current server and import it on the target server.

To export:

  1. From the power user interface of the KB you want to transfer, go to Setup > Export.
  2. On the Destination tab, choose where to save the file:
    • For small KBs, save the file to the local hard drive. This makes it easy to upload the file in the next section.
    • For large KBs greater than 1 GB in size, save the file to the home or TMP directory on the server.
  3. On the Data Format tab, select the  Agiloft format.
  4. On the Options tab, choose whether to disable the KB during the process. Disabling the KB prevents users from making changes to the content being exported, which is useful, but requires a certain window of time where no users need KB access. For large KBs, the export can take a long time, so plan accordingly.
  5. Choose how to handle file attachments. You can strip attachments entirely, or compress attachments into a .zip file. File attachments can significantly increase the size of the export file, especially for large KBs.
  6. Enter any comments.
  7. Click Finish.
  8. If you saved the KB to the server, access the server now and move the file to the TMP directory on the target server. This requires server access.

You can also use the Backup function in the admin console to export a KB. For more information, see Creating Backup Files.

To import:

  1. From the admin console of the target server, go to KB Management > Import.
  2. Select the source and file name for the KB file you need to transfer.
  3. In the Knowledgebase Name field, enter a name for your knowledgebase.
  4. Configure any remaining options as desired.
  5. Click Finish.

Version Considerations

You can transfer KBs from a lower version to a higher version, but not from a higher version to a lower version. To see the current version, log in and go to Help > About  Agiloft in the upper right corner.

Additional considerations apply when transferring a KB from version 2018_02 or below to version 2019_01 or above. In most cases, it's best to upgrade the lower version KB first and then create a new backup instead. However, if necessary, you can transfer a KB between these versions if you host  Agiloft on your own server.

To transfer a KB from version 2018_02 or below to version 2019_01 or above:

  1. Using the steps above, export the low-version KB to a backup file.
  2. Upgrade  Agiloft to the RC_2019_01 version of  Agiloft. Use the install file here to upgrade directly to the RC_2019_01 version without automatically upgrading beyond it to 2019_01.
  3. Import the backup file into a RC_2019_01 KB on the upgraded server.
  4. Export the RC_2019_01 KB to a backup file.
  5. Import the backup file to the higher-version KB, 2019_01 or any later version.