Page tree
Skip to end of metadata
Go to start of metadata

Import Export

Record data can be imported into Agiloft in standard formats such as ASCII, Excel, XML, Salesforce, etc. You can also import from a backup of a knowledgebase in Agiloft's standard format. The same formats are available when exporting data.

Let us help you find what you're looking for...

Import and Export Wizards

The Import and Export wizards are used to transfer information between  Agiloft tables and text files or spreadsheets.

Access Points

There are two places to find import and export options, the global import/export from the Setup menu and a table-specific import/export wizard. Use the table Import or Export when working with record data that belongs in a single table. Global imports and exports allow you to export/import data from multiple tables at once and is only accessible if you have administrator access to the Setup menu. Non-administrator users can use the table Import/Exports wizards; this group permission is granted on a per-table basis.

Table Import and Export Wizards – Data in a Single Table

To open the record data Import/Export wizard for a single table, follow these steps:

  1. Navigate to the table in the left pane.
  2. Hover over Actions in the action bar.
  3. Select Import or Export to open the wizard.

The Import and Export wizards both contain the following data source and data format options.

Available File Locations for Import and Export

The available source or target data locations are:

  • Local hard drive
  • TMP directory
  • Server home directory
  • Microsoft Outlook

Available Data Formats

Table data can be imported or exported directly to, or from, the following formats:

  • Tab-delimited text
  • Other text file
  • Excel '97 spreadsheet (.xls). Note that if you export to this format, the size of the export cannot exceed the value (in megabytes) set in the Maximum XLS Size To Export global variable. 
  • Excel '07 spreadsheet (.xlsx)
  • XML file
  • JSON

Table Export Wizard

The three tabs of the Export wizard are: Destination, Data Format, and Options.

Options Tab

  • Choose to export selected records, records that are found based on a saved search, or all records in the table.
  • Choose whether to include existing labels or attached files.
  • Under Fields, you can choose to export all fields in the table, select fields individually by checking their associated box, or include records based on a certain view.

Table Import Wizard

The table Import wizard is comprised of seven tabs: Data Source, File Name, Data Format, Options, Table, Records, and Fields. For a detailed tutorial of the data import process and further import tips for users, please see Importing Record Data.

Options Tab

The Options tab contains the following:

  • Workflow/Rules - choose whether to run rules after import, and to execute workflow actions on import.
  • Password encryption format

Table Tab

The Table tab controls how the system handles missing choice values, conversion and import errors, date/time format, and other workflow options.

  • The drop-down under Table shows the current table and any associated subtables.

Records Tab

The option we select on the Records tab regarding how the import will act on existing records is an important one and changes the way the system handles the import.
  • Append new records: Adds new records only, without affecting existing records.
  • Replace matching records: If a match is found, current  Agiloft records are overwritten and completely replaced by the data contained in the import file.
  • Skip matching records: If a match is found, the import action skips the record and ignores the data contained in the import file for that record, leaving the  Agiloft record unchanged.
  • Update imported fields only in matching records: If a match is not found, the import ignores the data contained in the import for non-matching records and no data is copied to  Agiloft. If a match is found, the import action updates the record with the data contained in the import file, leaving any fields not contained in the import file unchanged.
  • Delete all records before importing: The system deletes all existing records prior to the import.
Note: If you choose Replace matching records, Skip matching records, or Update imported fields only in matching records, it is important to provide a field that will identify a matching record.  If you don't provide this field the system will add records for all values in your file. Under 'Match records,' select a field like ID that is unique and exists in your document.

Fields Tab

The Fields tab displays a list of your data types and drop-down lists of existing fields in the system.  Agiloft attempts to perform default mappings based on field type, but typically the user needs to manually match all import fields to existing table fields prior to import. The best way to create an import spreadsheet template is to export a single record from the table of interest to create a spreadsheet labeled with the exact field names.   

Note: Some tabs only appear for users with permission to import or export multiple records to a file. This permission setting is defined on the Permissions tab for the user group.

During imports the system displays a progress message about what sheet and row is processing. Once the update is in progress you can leave the import page.

Import and Export Wizards – Data from Multiple Tables

To access the Import or Export wizards, navigate to Setup > Import or Setup > Export.


Available File Locations for Uploading and Downloading

  • Local hard drive
  • TMP directory
  • Server home directory

Import Wizard

The table Import wizard contains six tabs: Data Source, File Name, Data Format, Options, Records, and Fields.

Available Data Formats

  • Salesforce data
  • Tab-delimited text
  • .TGZ file with multiple text files/attachments
  • Other text file
  • Excel spreadsheet
  • XML file

Options Tab

The Table tab controls how the system handles:

  • The first row of data
  • Missing choice values
  • Conversion and import errors
  • Date/time format
  • Workflow options
  • Passwords

At the bottom of the wizard, choose the table where the data should be imported. To import data into multiple tables, each table's data should be on a separate sheet of the Excel workbook.

Note: If you are importing multiple sheets to multiple tables at once, it is important to consider if the records are supposed to be linked. For example, if your users are linked to companies, the company information should be imported first. If you use the global Import wizard to import both sheets at once, the system will import the data sequentially, in the order that the sheets appear in the workbook. If the worksheets are not in the right order, the imported record data may not link properly.

Note: The system can create missing choice values from the imported data, as long as the choice list is not a reserved system choice list.

Records Tab

The option we select on the Records tab regarding how the import will act on existing records is an important one and changes the way the system handles the import.
  • Append new records: Adds new records only, without affecting existing records.
  • Replace matching records: If a match is found, current  Agiloft records are overwritten and completely replaced by the data contained in the import file.
  • Skip matching records: If a match is found, the import action skips the record and ignores the data contained in the import file for that record, leaving the  Agiloft record unchanged.
  • Update imported fields only in matching records: If a match is not found, the import ignores the data contained in the import for non-matching records and no data is copied to  Agiloft. If a match is found, the import action updates the record with the data contained in the import file, leaving any fields not contained in the import file unchanged.
  • Delete all records before importing: The system deletes all existing records prior to the import.

Export Wizard

The Export wizard is used to export information from multiple tables in a knowledgebase and can create a full backup. In addition to the standard formats provided by table import or export–tab delimited, CVS, and Excel spreadsheet–the global wizard allows you to export into  Agiloft's proprietary format, which adds the ability to transfer table definitions and optionally export data, including: scripts, escalation rules, inbound email definitions and other customizations. For more information, please refer to Importing Record Data.

Available Data Formats

  • Agiloft
  • Tab-delimited text
  • Other text file
  • Excel '97 spreadsheet (.xls). Note that if you export to this format, the size of the export cannot exceed the value (in megabytes) set in the Maximum XLS Size To Export global variable. 
  • Excel '07 spreadsheet (.xlsx)
  • XML file

Tip: The  Agiloft format uses XML to represent the data and tar, gzip to compress it. The extension .ew appears on any files exported in this format.

Knowledgebase Import and Export

An alternative to the simple import/export of a single table is offered via the Import and Export wizards. These wizards provide all the source location, format options and field mapping as the table import/export but also facilitate the transfer of a complete knowledgebase, or several tables by means of a single file.

In addition to the standard formats provided by table import/export (i.e. tab delimited, csv and Excel spreadsheet), you can also export into Agiloft's proprietary format. This has the added capability of transferring the table definitions and optionally exporting data, scripts, escalation rules, inbound email definitions and other customizations. All tables in the knowledgebase are transferred when utilizing the Agiloft format.

The standard transfer formats (.txt, .csv & .xls) may be used to transfer all knowledgebase tables, but can also transfer a selected subset of the tables in the knowledgebase.

Using the knowledgebase import/export, you can transfer entire knowledgebases from one server to another. To make the transfer, export your knowledgebase in Agiloft format and then import it on the target server.

Only the users with project import/export permissions can export the entire knowledgebase in Agiloft format. To give a group import/export permissions for your knowledgebase, navigate to Setup > Access > Manage Groups, edit the relevant group, click the General tab and enable the "Allow importing knowledgebase" or "Allow exporting knowledgebase" options.

You can only import a knowledgebase in SW ( Agiloft) format using the Admin Console. From there, navigate to Setup > Import and enter the name for the new knowledgebase. It is no longer possible to import Agiloft KBs using the Import wizard from within the Power User Interface.

Transfer a Knowledgebase to a Different Server

You can use the knowledgebase export/import wizard to transfer an entire knowledgebase from one server to another.

To export:

  1. Navigate to Setup > Export.
  2. On the Destination tab choose Local hard drive. 
  3. On the Data Format tab select  Agiloft.
  4. Click Finish.

To import:

  1. From the admin console of your server, navigate to Setup > Import.
  2. Enter a name for your knowledgebase.
  3. Click Finish.

Note: Only the users with project import/export permissions can export the entire knowledgebase in Agiloft format. To give a group import/export permissions for your knowledgebase:

  1.  Navigate to Setup > Access > Manage Groups.
  2. Edit the relevant group.
  3. Navigate to the General tab and select the "Allow importing knowledgebase" or "Allow exporting knowledgebase" options.

Agiloft